13
FORMATTING WORKSHEETS

13.1 INTRODUCTION
Excel has a number of formatting options to give your worksheets
a polished look. You can change the size, colour and angle of
fonts, add colour to the borders and backgrounds of cells, and
have the format of a cell change, based on its value. You may
remember some of the formatting features in MS Excel are same
as you have used in MS Word.
13.2 OBJECTIVES
After going through this lesson you would be able to
l

use autoformat features

l

format data and worksheets

l

explain format painter

13.3 USING FORMATTING TOOLBAR TO FORMAT CELLS
The contents of a highlighted cell can be formatted in many
ways. Font and cell attributes can be added from shortcut buttons
on the formatting bar. If this toolbar is not already visible on the
→ Formatting
→Toolbars→
screen in your computer, select View→
from the menu bar.
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Fig. 13.1

13.3.1 Formatting Cells Using Dialog Box For a complete list
of formatting options, right-click on the highlighted cells and
choose Format Cells from the shortcut menu or select
→Cells from the menu bar.
Format→

Fig. 13.2

13.3.2 Number tab
The data type can be selected from the options on this tab. Select the range you would like to format and click on one of the
Category number as shown in Figure 13.2 to apply that style to
your numbers. Select General if the cell contains text and
number and it does not have any specific number format. If you
select Number Category you can represent numbers as integers, decimals with number of decimal as option etc. For exam-
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ple, if you want to restrict the number of decimals to 2, choose
Number Category and then decimal places as 2. You may try
the other options in your computer.
13.3.3 Alignment tab
These options allow you to change the position and alignment of
the data with the cell. You have already seen some of these options in Figure 13.1. The Format Cells dialog box offers you
more options than the alignment buttons on the Formatting
toolbar. For example, you can change the orientation of the
text.
13.3.4 Font tab
All of the font attributes are displayed in this tab including font
face, size, style, and effects. Using Formatting toolbar you can
bold, italicize, and underline your cell entries. For even more
formatting options you can use the Format Cells dialog box.
13.3.5 Border and Pattern tabs
You can also use the Formatting toolbar for adding borders, cell
shading, and font colour. These buttons are actually tear-off
palettes. When you click on the picture portion of the button,
the format of the picture displayed will be applied to the contents of the cell(s) you have selected in the worksheet. You can
change the picture displayed on the button by clicking on the
button’s small drop-down arrow to access the palette of samples
from which to choose.
Follow these steps to apply a border and colour to a selection
using the options in the Format Cells dialog box.
→Cells to display the Format Cells dialog box.
1. Select Format→
2. Select the Border tab.
3. In the Presets area, choose None, Outline, or Inside to specify
the location for the border.
4. Choose any of the following options for the border:
–

In the Border area, click on any of the buttons to toggle
its border.

–

Choose the border’s line style in the Style area.

–

If necessary, select a colour for the border in the Color
Palette.
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5. Select the Patterns tab, and then choose any of the following options:
–

Select a colour for the background of the selection in
the Color palette.

–

If necessary, select a pattern for the background of the
selection in the Pattern palette.

6. Choose OK to apply the border and colour.
13.3.6 Dates and Times
If you enter the date “January 1, 2001” into a cell on the
worksheet, Excel will automatically recognize the text as a date
and change the format to “1-Jan-01”. To change the date format,
select the Number tab from the Format Cells window. Select
“Date” from the Category box and choose the format for the date
from the Type box. If the field is a time, select “Time” from the
Category box and select the type in the right box. Date and time
combinations are also listed. Press OK when finished.

Fig. 13.3

13.3.7 Formatting Columns and Rows
You have learned how to resize columns and rows. You can also
use AutoFit Selection feature. It adjusts a column width or a row
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height according to the widest entry of a column or tallest height
→Columns→
→AutoFit
of a row. To use this feature select Format→
Selection commands. It adjusts the width of the column according
to the widest entry in that column. Similarly, you can select
→Rows→
→AutoFit Selection commands. It increases the
Format→
height of the row(s) to accommodate the tallest character in a
row.
Another way of automatically adjusting columns and rows is by
way of best fit. To do this:
1. Place your pointer on or near the right edge of a column
header of the column you wish to adjust. Notice that in this
area your pointer changes to a double-headed arrow.
2. Double click your pointer, and the column to the left of it
will automatically adjust to fit the data entries within it.
Similarly, pointing to a row header changes pointer to a doubleheaded arrow. Double clicking results in a best fit (taller or shorter
rows).
Hide - Hides the selected column(s) or row(s), though the data is
still there. Hiding column(s) or row(s) will help you to prevent
unwanted changes. To hide a column, follow these steps:
1. Select the column you want to hide by clicking on the column
header.
→Column→
→Hide from the menu bar or right
2. Select Format→
click within the selected columns and choose Hide from the
shortcut menu that pops up. The columns should be hidden.
Unhide - To unhide the column follow these steps:
1. Select the visible range of columns that includes the hidden
column(s).
→Column→
→Unhide from the menu bar or right
2. Select Format→
click within the selected columns and choose Unhide from
the shortcut menu that pops up. The columns should now
reappear.
You can follow the same procedures to Hide and Unhide rows.
13.4 FORMATTING WORKSHEETS USING STYLES TOOLBAR
The use of styles in Excel allow you to quickly format your
worksheet, provide consistency, and create a professional look.
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In Excel, all styles are cell styles. However, a defined style can
be applied to an entire worksheet. Cell styles can include any of
the formatting that can be applied to a cell using the options on
the tabs in the Format Cells dialog box. Select the Styles dropdown box from the formatting toolbar (it can be added by
customizing the toolbar). Excel provides several preset styles:

Fig. 13.4

1. Comma - Adds commas to the number and two digits beyond a decimal point.
2. Comma [0] - Comma style that rounds to a whole number.
3. Currency - Formats the number as currency with a dollar
sign, commas, and two digits beyond the decimal point.
4. Currency [0] - Currency style that rounds to a whole number.
5. Normal - Reverts any changes to general number format.
6. Percent - Changes the number to a percent and adds a percent sign.
13.4.1 Applying a Style in an Excel Worksheet
In order to apply an existing style in Excel, follow the steps given
below:
1

Select the cells to which you want to apply a defined style.

2

Choose Format→
→Style to display the Style dialog box.

3

Select the name of the style to apply in the Style Name dropdown list.

4

Select OK.
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13.4.2 Creating or Modifying a Style in Excel
You can create your own styles or modify an existing style using
Style dialog box. Follow the steps given below:
1. Highlight the cell(s) you want to add a style to.
2. Select Format→
→Style... from the menu bar.

Fig. 13.5

3. Modify the attributes by clicking the Modify button.
4. Check all the items under Style includes that the style
should format.
5. Click Add to preview the formatting changes on the
worksheet.
6. Highlight the style you want to apply to the paragraph and
click Apply.
13.4.3 Name a New Style in Excel
1. Select the cell on the worksheet containing the formatting
you would like to set as a new style.
2. Click the Style box on the Formatting toolbar so the style
name is highlighted (see Figure 13.4).
3. Delete the text in the Style box and type the name of the
new style.
4. Press ENTER when finished.
13.4.4 Copying Styles in Excel
You can copy styles from one open workbook file to another:
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1. Activate the workbook to which the styles are to be copied.
→Style, and then choose Merge to display
2. Choose Format→
the Merge Styles dialog box.
3. Highlight the name of the workbook that contains the styles
to be copied in the Merge Styles from list box.
4. Choose OK in the Merge dialog box.
5. Choose OK in the Style dialog box to return to the workbook.
13.4.5 Deleting Styles Other Than Excel’s Built-in Styles
To delete a style other than one of Excel’s built-in styles, select
→Style to display the Style dialog box, select the name
Format→
of the style in the Style name drop-down list, and then choose
Delete.
13.5 FORMAT PAINTER
A handy feature on the standard toolbar for formatting text is
the Format Painter. If you have formatted a cell with a certain
font style, date format, number format, border, and other
formatting options, and want to format another cell or group of
cells the same way, place the cursor within the cell containing
the formatting you want to copy. Click the Format Painter button
in the standard toolbar (notice that your pointer now has a
paintbrush beside it). Highlight the cells you want to apply the
same formatting. The formatting will change accordingly.
Also, to copy the formatting to many groups of cells, doubleclick the Format Painter button. The format painter remains
active until you press the ESC key to turn it off.
13.6 AUTOFORMAT
Excel’s AutoFormat feature uses table styles, which are
predefined collections of number formats, fonts, cell alignments,
patterns, shading, column widths, and row heights to have a
polished look of ranges of cells you specify. You can use these
styles as-is or over rule some of their characteristics.
Excel has many preset table formatting options. Add these styles
by following these steps:
1. Highlight the cells that will be formatted.
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Fig. 13.6

→AutoFormat from the Excel’s menu bar. A
2. Select Format→
dialog box will open with many table formats to choose from
and apply.
3. On the AutoFormat dialog box, select the format you want to
apply to the table by clicking on it with the mouse. Use the
scroll bar to view all of the formats available. Some of the
styles are shown in Figure 13.7.

Fig. 13.7

4. Click the Options... button to select the elements that the
formatting will apply to.
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5. Select from the many table styles. If you like one of the
formats but don’t want to apply every aspect of it, click on
the Options button. Choose from the Formats to apply
option box.
6. Click OK when finished.

Fig. 13.8

13.7 HIDING/UNHIDING WORKSHEETS AND WORKBOOKS
If you want to hide or unhide all row or columns on a worksheet,
select the whole worksheet by clicking the block at the intersection of the first row and first column headings. Once every thing
is selected, follow the same steps that you have followed for hiding/unhiding columns and rows.
To hide an active workbook, you don’t need to select any thing,
simply select Window→Hide from the menu bar. Select
Window→Unhide to bring it back into view using the Unhide
dialog box that opens and then name the workbook name you
want to unhide.
INTEXT QUESTIONS
1. Write True or False for the following statements.
(a) Format cells dialog box offers you more option than the
alignment buttons on the formatting toolbar.
(b) Click Edit to perview the formatting changes on the
worksheet.
(c) If the field is a time select "time" from the category box.
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(d) To unhide the column select format → colum → unhide
from the menu bar.
(e) Choose Edit → style to display the style dialog box.
2. Fill in the blanks
(a) Modify the _________ by clicking the modify button.
(b) In Excel all style are ______________.
(c) Hiding columns or rows will help you to __________ unwanted changes.
(d) It the tool bar is not already visible on the screen select__________.
(e) To change the data format select the __________ from the
format cells window.
13.8 WHAT YOU HAVE LEARNT
In this you learnt about various tools available in Excel to format
a worksheet. You can align text and change font size, style and
effects. Also you learnt how to put a border or shade to the text
in the cells selected by you. Also you learnt about applying style
to a worksheet and modify the style.
13.9 TERMINAL QUESTIONS
1. Explain the following terms in brief.
(a) AutoFit

(b) AutoFormat.

2. What is Format Painter? When do you think Format Painter
is useful in Excel?
3. Explain different preset styles available in Excel.
4. Explain steps to create a new style.
5. How to copy styles from one open workbook file to another?
6. What are the different tabs available in Format Cells dialog
box?
7. What are the different features available in:
(a) Number tab, (b) Border tab and (c) Patterns tab in Excel’s
Format Cells dialog box?
8. How do you: (a) Hide a column, (b) Unhide a column, (c)
Hide a worksheet, (d) Unhide a worksheet?
9. How do you resize your worksheet columns or rows?
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13.10 KEY TO INTEXT QUESTIONS
1. (a) True
(b) False
(c) True
(d) True
(e) False
2. (a) attributes
(b) cell style
(c) prevent
(d) view toolbar formatting
(e) number tab

